Product: Columbus
Harmony to Columbus connection - Common problems
Part A) Establishing a connection
Harmony establishes an initial connection to the Columbus server via a SOAP webservice which runs on the Columbus server and is served on port 8081 via a tomcat server. Inbound TCP traffic on port 8081 must be permitted on the Columbus server.
Problem:
The following error is shown in Harmony when configuring the Columbus user account.
"Cannot establish connection to Columbus. There was no endpoint listening at http://columbus:8081/axis2/services/CCInterface2 that could accept the message."
Possible causes:
1. The "tomcat6" service is not running correctly on the Columbus server.
2. The Columbus server is not running
Problem:
The following error is shown in Harmony when configuring the Columbus user account.
"Cannot establish connection to Columbus. Please check the Columbus account information."
Possible causes:
1. The Columbus user account information is incorrect.
Part B) Image Transfer
Once the transfer has been initiated, Harmony pushes a txt file to the Columbus server that contains a list of URLs which describe the individual image locations on the Harmony workstation, e.g...
http://oprt1234/path/to/image1.tiff
http://oprt1234/path/to/image2.tiff
http://oprt1234/path/to/image3.tiff
...and so on, where "oprt1234" is the short hostname of the Harmony workstation.
Columbus uses the URLs to pull the images directly from the Harmony workstation. Inbound TCP traffic on port 80 must be permitted on the Harmony machine, and the Columbus server must be able to resolve the IP address of the Harmony workstation using the short hostname only.
Problem:
The Harmony transfer job appears in the Columbus job status page with a "Failed" status. The following error appears in the /var/log/columbus/acc/acc.log...
Error: Can't connect to oprt1234: 80: Connection timed out
...where "oprt1234" is the short hostname of the Harmony workstation.
Possible causes:
1. The Columbus server is unable to establish a connection to the Harmony workstation on port 80. Inbound traffic on port 80 is blocked either by the Harmony workstations firewall, or some other network firewall/router, etc.
2. The short hostname of the Harmony workstation is resolving to an incorrect/non-existant IP address (possibly due to a fixed hosts file entry on the Columbus server), which is not permitting inbound TCP traffic on port 80.
Problem:
The Harmony transfer job appears in the Columbus job status page with a "Failed" status. The following error appears in the /var/log/columbus/acc/acc.log...
Error: Cannot resolve server name "oprt1234"
...where "oprt1234" is the short hostname of the Harmony workstation.
Possible causes:
1. The Columbus server is unable to translate the short hostname of the Harmony workstation into a valid IP address.
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