Date Posted:
Product: Columbus
Product: Columbus
Problem:
Why are imported data sets not appearing in AWS S3 storage, and Batch Analysis jobs stuck in Submitting state?
Solution:
Problem:
Imported data not copied to S3 and Batch Analysis jobs stuck in submitting state
Errors similar to those shown below are seen in the /var/log/columbus/web/long-tasks.log file.
EndpointConnectionError: Could not connect to the endpoint URL: "https://s3.eu-west-1a.amazonaws.com/"
EndpointConnectionError: Could not connect to the endpoint URL: "https://elasticmapreduce.eu-west-1a.amazonaws.com/"
Cause:
The AWS endpoint is invalid because "eu-west-1a" is not a valid region ("eu-west-1" is correct).
Solution:
Ensure that the AWS "region_name" parameter in the cluster config file found in /etc/columbus points to a valid AWS region.
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