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Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Error when using Spotfire data connector for Cloudera Impala with Kerberos authentication method
Solution:
When using the Spotfire data connector for Cloudera Impala with Kerberos authentication, it fails to establish a successful connection with the database. It may throw the following error:
ERROR [HY000] [Cloudera][ImpalaODBC] (230) The current connection is trying to use the saslGSSAPI plugin but the SASL library has already been configured to use the saslSSPI plugin by a previous connection. Using different SASL Kerberos plugins simultaneously in the same application is not supported.
Cause:
If SSPI options for the Impala DSN are not selected, it may result in the error listed above.
1) Open the ODBC connectivity settings dialog for Cloudera Impala DSN
2) Click on "Advanced Options"
3) Under “Use Only SSPI” section, select “Enable for this DSN” and “Enable for DSN-less connections” options
4) Click on "Ok" and "Ok" again
5) Test the connectivity
Here is a screenshot for this configuration:
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