Product: TIBCO Spotfire®
Web Player error: 'The requested analysis is not loaded on the server'
Description:
Description of different scenarios that can lead to the error 'The requested analysis is not loaded on the server' in TIBCO Spotfire Web Player.
Symptoms:
The Web Player shows one of the following variations of an error message:
The requested analysis is not loaded on the server.
The analysis with id <analysis-id> is not found in session <session-id>.
This may indicate that the server has been restarted.
or
The requested analysis is not loaded on the server.
The analysis with id <analysis-id> is not found in application instance <appinstance-id>.
This may indicate that the server has been restarted.
Cause:
There are a few different scenarios that can lead to the error. What they have in common is that the Web Player server has received a request containing an analysis and/or session id which it does not recognize.
Scenario 1: The Web Player has restarted
When the Web Player restarts, all user sessions will be lost. The error message will appear for all users that have analyses open while the Web Player was restarted.
Two messages stating that the server has shut down and is about to start will be logged in <Web Player install dir>\Logfiles\Spotfire.Dxp.Web.log every time the Web Player restarts. Searching for "Web application starting" in the log will let you know if and when the server has started.
INFO 2013-04-01 00:00:00,234 [123, (null)] Spotfire.Dxp.Web.SiteManager - Web Player server shut down on host 'HOSTNAME'.
INFO 2013-04-01 00:00:01,123 [1, (null)] Spotfire.Dxp.Web.Forms.Global - Web application starting...
Any changes made <TIBCO Spotfire Web Player install dir>\webroot\Web.config will trigger the Web Player to restart as well some changes made from Internet Information Services (IIS) Manager.
Tip: Perform configuration changes and restarts during dedicated maintenance windows when no users are expected to use the Web Player.
Scenario 2: User's session timing out
A session will eventually time out on the Web Player server if the user's web browser has been inactive and unable to send requests to the Web Player for a longer period of time. It can e.g. occur if the user's operating system has been put into hibernation mode and then started again after the session has timed out. The error above will be displayed because the web browser is making a request using a session which has already been removed by the Web Player.
Scenario 3: Load balancer not configured for session affinity
A load balancer that sits between the end user's web browser and the Web Player, forwarding requests and responses back and forth, which is not properly configured to handle "session affinity" may also be the cause of the error. "Session affinity", also called "sticky sessions" sometimes, is a property of the load balancer which ensures that all requests for any one session always end up on the same server. It is a requirement for load balancers handling Web Player clusters because a session exists in one Web Player node only and is not valid for the rest of cluster.
Tips on session affinity
There are a few different methods the load balancer can use to keep track of where each request should be routed so it ends up on the right Web Player server. For example:
- Inject a session cookie in the first response and use it to determine where to forward subsequent requests. The cookie value can be the name as the server/route to where the request should go. The load balancer must have the ability to inject a cookie, hence operate on the HTTP network layer.
- Use client's source IP address to partition the load. A certain source IP will use a particular Web Player server. The load balancer may distribute users unevenly if most of the users originate from a few IP addresses (possibly proxies) only. It will not work well if user's IP addresses are dynamic and are likely to change during an ongoing session.
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