Product: TIBCO Spotfire®
Custom DatePicker renders in Web Player but not in Spotfire Professional/Analyst client.
Spotfire version 6.5.
The custom JS DatePicker is not displayed when the Text Area is rendered. This issue occurs only in the Spotfire Professional/Analyst desktop client. The issue is not seen in Web Player clients.
Cause:
The problem occurs in Spotfire Professional/Analyst client version 6.5.x because in order to render HTML Text Area visualizations, the 6.5.x desktop client uses a third party component from Microsoft: the .Net WebBrowser control, which runs Internet Explorer in IE 7 compatibility mode. This means that the custom JavaScript code written in text areas needs to support IE 7 in order to work. However, the custom JS code for DatePicker (provided by 'http://static.jude.io/datepicker/') supports only IE 10 or higher.
Resolution
One option is to force the web browser component to run in a different mode than IE 7 compatibility mode by setting a registry key on the PC which runs the Spotfire Professional client. In the Windows registry, you would add a DWORD entry with the key "Spotfire.Dxp.exe" to:
HKEY_LOCAL_MACHINE (or HKEY_CURRENT_USER)\Software\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_BROWSER_EMULATION . Set it to 11000 for IE 11 (or 10000 if IE 10 is installed in the host computer).
For more details on this value, refer to https://msdn.microsoft.com/en-us/library/ee330730(v=vs.85).aspx#browser_emulation. Note that this is only a workaround, and it is not officially supported. In some cases it might cause an unexpected behavior in other parts of the application that use the web browser component. Another option is to engage TIBCO Spotfire Professional Services to make the JavaScript code support IE 7.
Comments
0 comments
Article is closed for comments.