Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Resolution for Web Player Exception : Spotfire.Dxp.Internal.Diagnostics.PerformanceCounterUtils - Exception in setting up the performance counters. System.UnauthorizedAccessException: Access to the registry key 'xxxx' is denied.
Solution:
Description:
This article describes the resolution for following Exception in the Web Player log files:
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Spotfire.Dxp.Internal.Diagnostics.PerformanceCounterUtils - Exception in setting up the performance counters.
System.UnauthorizedAccessException: Access to the registry key '238' is denied.
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Symptoms:
The following exception can appear after enabling performance counter logs in Web Player.
INFO 2015-03-02 14:48:24,581 [11392, 28, (null)] Spotfire.Dxp.Internal.Diagnostics.PerformanceCounterUtils - Exception in setting up the performance counters.
System.UnauthorizedAccessException: Access to the registry key 'xxxxx' is denied.
at Microsoft.Win32.RegistryKey.Win32Error(Int32 errorCode, String str)
at Microsoft.Win32.RegistryKey.InternalGetValue(String name, Object defaultValue, Boolean doNotExpand, Boolean checkSecurity)
at Microsoft.Win32.RegistryKey.GetValue(String name)
at System.Diagnostics.PerformanceMonitor.GetData(String item)
at System.Diagnostics.PerformanceCounterLib.GetPerformanceData(String item)
at System.Diagnostics.PerformanceCounterLib.GetCategorySample(String machine, String category)
at System.Diagnostics.PerformanceCounter.NextSample()
at System.Diagnostics.PerformanceCounter.NextValue()
at Spotfire.Dxp.Internal.Diagnostics.PerformanceCounterReader.get_NextValue()
Cause:
The cause of this exception is the registry access permission to the Web Player Application pool identity. To resolve this issue, the Web Player Application pool identity needs to be added to the following two groups on the Web Player server machine.
1). Performance Monitor Users.
2). Performance Log Users.
Instructions:
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1). Open the Local Users and Groups node in the Computer Management MMC.
2). Open the "Performance Monitor Users" group and add the application pool identity that you are using. For example, if your application pool identity is "mydomain\username", then add the user “mydomain\username” to the above group.
3). Add the same user to 'Performance Log Users' group as well.
4). Restart your server for the changes to take affect.
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