Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Scheduled Updates won't initialize if the Web Player is using any of the Single Sign-On methods and the specified username is not a valid user account in the Active Directory
Solution:
Description:
Scheduled Updates won't initialize if the Web Player is using any of the SSO methods and the specified username is not a valid user account in the Active Directory.
Symptoms:
You will see an error message in the Web Player log which resembles the following:
ERROR 2014-09-22 08:57:50,654 [5088, 1, (null)] Spotfire.Dxp.Web.SiteManager - Failed to initialize the Scheduled Updates
System.ComponentModel.Win32Exception (0x80004005): Logon failure: unknown user name or bad password
at Spotfire.Dxp.Framework.Login.WindowsIntegratedAuthenticator.LogonUserOnComputer(String username, String password)
at Spotfire.Dxp.Web.Library.ScheduledUpdates.LoginScheduledUpdateUser(SiteManager siteManager, SpotfireIdentity identity)
at Spotfire.Dxp.Web.SiteManager.Configure(PerformanceSectionGroup settings, Styles styles, String webRootPath, Boolean startScheduledItems, ServerInformation info, Boolean isWorkerProcess, String nodeManagerServiceId)
Cause:
If Web Player is set to use any of the Single Sign-On methods (i.e., Windows authentication is set to enabled in IIS manager), then the username specified in the web.config file as the "Scheduled updates user" needs to exist in the Active directory. It is not enough that the user exists in the Spotfire environment as it needs to be a valid user account in the Active Directory as well. Make sure the user specified as the Scheduled updates user in the web.config file is a valid user account in the Active Directory. The Windows user account also needs to have "Allow logon locally" permissions to logon to the Server running the Web Player. See KB article 000019632 for further details. KB article 000019632
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