Keywords: Upgrade, Import Users, Administration manager, Spotfire 12.0
Details:
I am trying to import a txt file via the administration manager in Tibco Spotfire 12.0 and I’m getting the following error:
Error message: Could not import users.
UserDirectoryServiceException at Spotfire.Dxp.Services:
The imported document contains no password on line 2. (HRESULT: 80131509)
Stack Trace:
at Spotfire.Dxp.Services.WcfSoapService`2.InvokeService[T](Func`1 serviceMethod, String customMethodNameForLogging)
at Spotfire.Dxp.Forms.Application.Administration.AdministrationForm.<>c__DisplayClass54_0.<importUsersButton_Click>b__0()
at Spotfire.Dxp.Framework.ApplicationModel.Progress.<>c__DisplayClass22_0.<Start>b__0()
at Spotfire.Dxp.Framework.ApplicationModel.MonitorableProgress.Start[T](Func`1 action)
at Spotfire.Dxp.Forms.Application.FormsProgressService.ProgressThread.<DoOperationLoop>b__11_0()
Cause:
This is due to a syntactical error in the text file format used for importing users in Spotfire.
Below is the file format to bulk import the users:
User name;Domain name;password; display name;email
Correct syntax Example:
-----------
Test ; SPOTFIRE ;Test123; Test ; Test@mydomain.com
Test1 ; SPOTFIRE ; spotfire123;Test1 ; Test1@mydomain.com
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In above file format, if you put extra semicolon ( ; ) like below at the end of any line by mistake, it throws error for that particular line number while importing users: Incorrect number of columns in line #XX: expected 5, was 6
Erroneous example:
------------
Test ; SPOTFIRE ;Test123; Test ; Test@mydomain.com;
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