Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Export to PDF or Print does not work or hangs.
Solution:
Description:
Export to PDF, Print from Webplayer hangs.
Symptoms:
When the 'Export PDF' option is chosen in the Menu, it goes to the pop up window to customize the PDF. As soon as the user hits 'Finish' to start the export, it will freeze at the pop up window:
'Exporting to PDF
Exporting page x out of y.
If clicking 'Cancel', it freezes the whole screen unless the user closes the browser.
Below error may return in the webplayer logs
Error - "System.Runtime.InteropServices.COMException (0x800703FA): Illegal operation attempted on a registry key that has been marked for deletion. (Exception from HRESULT: 0x800703FA) "
Cause:
A user has recently logged onto the Controller application server, and then afterwards logged off again using the Windows username/password that is running the Controller system in the background. In other words, someone has recently logged off the Controller application server who was logged onto Windows using the Controller COM+ user account.
Follow the below steps:
1. Logon to the application server as an Administrator .
1. Logon to the application server as an Administrator .
2. Launch the group policy editor (click "Start - Run" then type "gpedit.msc").
3. Navigate to "Computer Configuration -> Administrative Templates -> System-> UserProfiles".
4. Double-click on "Do not forcefully unload the user registry at user logoff".
5. Change the setting from "Not Configured" to "Enabled". TIP: 'DisableForceUnload' is the value added to the registry.
6. A short period of downtime will be required (no users on the system) and reboot the application server to confirm that the change has been registered.
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