Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
The TIBCO Spotfire Professional Client exits unexpectedly on launch when TIBCO Spotfire Server is configured with the Windows Single-Sign On and 'Never display login dialog' option.
Solution:
The TIBCO Spotfire Analyst client exits unexpectedly on launch from the splash screen, with no apparent errors or exceptions, when it is connecting to a TIBCO Spotfire Server that is configured with Windows Single-Sign On authentication and the 'Never display login dialog' option is used, as set here:
- TIBCO Spotfire Configuration Tool > "Configuration" > "Login Dialog" > Configure Login Dialog Behavior: Display login dialog: "Never display login dialog"
Cause:
A defect causes the client to silently exit when no credentials are sent from the Spotfire Client which results in the login failing. The documentation states to set the TIBCO Spotfire Server Login Dialog Behavior to "Never display login dialog" but the issue will not occur if this is set to "Display unless user has saved login information". Via Configuration Tool:
Change this setting:
- TIBCO Spotfire Configuration Tool > "Configuration" > "Login Dialog" > Configure Login Dialog Behavior: Display login dialog:
- "Never display login dialog"
- "Display unless user has saved login information"
Via command line config utility:
Run the config-login-dialog command to set the Spotfire client login dialog behavior:
- > config config-login-dialog --allow-user-provided-credentials=standard
- https://docs.tibco.com/pub/spotfire_server/6.5.2/doc/pdf/TIB_sfire_server_doc_ServerInstallationManual.pdf
- p 71, Chapter 4.7.2 Kerberos Authentication, Chapter 4.7.2.1 Configuration Instructions
- Excerpt: "If you are using the Configuration Tool, select Never display login dialog for the Login dialog option"
Comments
0 comments
Article is closed for comments.