Product: TIBCO Spotfire®
Users fails to Login into Spotfire with NTLM Authentication with error: "Caused by: jcifs.smb.SmbException: Logon failure: user not allowed to log on to this computer."
Users are unable to login to Spotfire in NTLM SSO Authentication setup.
Symptoms:
1) Login Failure in Spotfire in NTLM SSO Authentication.
2) The TIBCO Spotfire Server logs shows the following message:
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DEBUG 2018-01-04T08:51:52,972+0930 [unknown, #7] server.security.JespaAdapter: NTLM authentication error
jespa.security.SecurityProviderException: NETLOGON failure
at jespa.ntlm.NtlmSecurityProvider.authenticate(NtlmSecurityProvider.java:1397)
at jespa.ntlm.NtlmSecurityProvider.acceptSecContext(NtlmSecurityProvider.java:1174)
at com.spotfire.server.security.JespaAdapter.authenticateNTLM(JespaAdapter.java:297)
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Caused by: jcifs.smb.SmbException: Logon failure: user not allowed to log on to this computer.
at jespa.ntlm.Netlogon.validate0(Netlogon.java:629)
at jespa.ntlm.Netlogon.validate(Netlogon.java:713)
...........
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Cause:
Error: "Caused by: jcifs.smb.SmbException: Logon failure: user not allowed to log on to this computer.", states that the user does not have login permission on Spotfire Server machine.
Logon permissions to Spotfire server machine needs to be given to the failed login user in Active Directory.
Instructions to enable the permissions:
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1). Login to Active Directory Server as Domain Controller Administrator. Open Active Directory Users and Computers Console ( All Program -> Administrative tools - > Active Directory Users and Computers or Run -> DSA.MSC ).
2). Browse and select the affected USER (S). Right Click on the UserName -> Go to Properties.
3). Select “Account” Tab and then click on “Log On To” button.
4). Make sure the radio button for “All Computers” is selected or if “The following computers” option is selected then the Spotfire Server computer name must be present in the Computer name list.
Attached document (Filename: Logon_to_all_Computer_Permissiion.docx) shows the steps with screenshots.
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