Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Users with usernames containing the ‘@’ character might not able to login to Spotfire
Solution:
Description:
If a username has the '@' character, like an Email ID, then that user might not be able to login to Spotfire.
Symptoms:
Users are unable to login to Spotfire.
Cause:
By default, Spotfire is configured to parse a username containing the '@' character into a username and domain name. For example, if a user is added with the User ID as its Email ID (test@MYDOMAIN.COM) then during the login process, Spotfire takes only "test" as the username and separates "MYDOMAIN.COM" as the domain name and tries the authentication procedure for user "test" which results in a login failure.
To resolve this issue, the "Parse User and Domain Name" option in the server configuration must be disabled. The following instructions describe the steps to disable user and domain name parsing.
Using Configuration Tool
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- Open the Configuration Tool. (Run <TSS installation Dir>\tomcat\bin\uiconfig.bat OR All Programs -> TIBCO Spotfire Server <version> -> Configure TIBCO Spotfire Server).
- Go to the Configuration Tab -> Domain
- Select the 'No' option for the 'Parse user and Domain name' property.
- Save the configuration and restart the server.
Configuration can also be changed using commands
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- Open a command prompt/shell.
- Browse to the <TSS Installation Dir>\tomact\bin directory.
- Export the current running configuration into a Configuration.xml file using the following command.
config export-config -f
- Run the following command to Disable User and Domain Name parsing.
config config-auth -p false
- Import the modified configuration into the database using the following command.
config import-config -c "Disabled User and Domain Name Parsing"
- Restart the server.
https://docs.tibco.com/pub/spotfire_server/7.11.0/doc/html/TIB_sfire_server_tsas_admin_help/GUID-4FCDEBC2-E4CA-4913-84C9-D6EF76CCE49B.html
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