Date Posted:
Product: TIBCO Spotfire®
Product: TIBCO Spotfire®
Problem:
Error installing TIBCO Spotfire Web Player: "Microsoft IIS must be installed before trying to install this application"
Solution:
When trying to install the TIBCO Spotfire Web Player, you get the following error: "Microsoft IIS must be installed before trying to install this application" despite the fact that Internet Information Services (IIS) is already installed.
Symptoms:
Users cannot install TIBCO Spotfire Web Player software on their machine. Users see this error message "Microsoft IIS must be installed before trying to install this application." even if Internet Information Services (IIS) is already installed.
Cause:
If Internet Information Services (IIS) is moved from its original installation location, the "PathWWWRoot" registry keys may still be pointing to the original location. Spotfire will read these registry keys during the TIBCO Spotfire Web Player installation and if they do not match and point to the current IIS installation path then Spotfire will determine that IIS is not installed and will return the "Microsoft IIS must be installed before trying to install this application" error:
The following IIS registry keys must match and point to the current IIS webroot directory:
- HKEY_LOCAL_MACHINE\Software\Microsoft\InetStp\PathWWWRoot
- HKLM\Software\Wow6432Node\Microsoft\InetStp\PathWWWRoot
- Open Internet Information Services (IIS) Manager. For example: Start > All Programs > Administrative Tools > Internet Information Services (IIS)
- Navigate to the "Default Web Site": In the "Connections" pane, expand the server node, then expand "Sites"
- Right click on "Default Web Site" and select "Explore"
- Windows Explorer will be opened to your default webroot directory. For example: D:\Inetpub\wwwroot
Correct the registry entries:
- Click Start button on Server.
- Type "regedit" in search text, Right click and "Run as Administrator".
- Verify that "HKEY_LOCAL_MACHINE\Software\Microsoft\InetStp\PathWWWRoot" exists and points to the webroot of your IIS server as determined above. If it does not match your webroot location, update the registry path manually to point it to webroot. For example, change it from "%SystemDrive%\inetpub\wwwroot" to "D:\Inetpub\wwwroot".
- On 64-bit systems, also verify that "HKLM\Software\Wow6432Node\Microsoft\InetStp\PathWWWRoot" exists and points to the webroot of your IIS server as determined above. If it does not match your webroot location, update the registry path manually to point it to webroot. For example, change it from "%SystemDrive%\inetpub\wwwroot" to "D:\Inetpub\wwwroot".
- Close the Registry Editor
- Re-run the Spotfire Web player Installation and it should let you install the application this time.
- If you still have Issues installing the application, Please open a support request at https://support.tibco.com.
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