Product: TIBCO Spotfire®
Unable to start Spotfire Server service due to port conflict. ERROR (java.net.BindException: Address already in use: JVM_Bind ;null;: ;port ;).
Description:
Unable to browse the Spotfire server URL (Admin Console) or Start the Spotfire server service. Error reported in "<Spotfire Server install directory>\tomcat\logs\catalina.log".
---------------------------------------------------
Caused by: java.net.BindException: Address already in use: JVM_Bind <null>:<port>
----------------------------------------------------
Symptoms:
Port conflict.
=================================================================
"Address already in use: JVM_Bind <null>:8080" OR "Address already in use: JVM_Bind"
=================================================================
SEVERE: Failed to initialize connector [Connector[HTTP/1.1-8080]]
org.apache.catalina.LifecycleException: Failed to initialize component [Connector[HTTP/1.1-8080]]
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:106)
:
:
at java.lang.reflect.Method.invoke(Method.java:483)
at org.apache.catalina.startup.Bootstrap.load(Bootstrap.java:280)
at org.apache.catalina.startup.Bootstrap.main(Bootstrap.java:454)
Caused by: org.apache.catalina.LifecycleException: Protocol handler initialization failed
at org.apache.catalina.connector.Connector.initInternal(Connector.java:980)
at org.apache.catalina.util.LifecycleBase.init(LifecycleBase.java:102)
... 12 more
Caused by: java.net.BindException: Address already in use: JVM_Bind <null>:8080
at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:411)
at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:646)
at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:434)
at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)
at org.apache.catalina.connector.Connector.initInternal(Connector.java:978)
... 13 more
Caused by: java.net.BindException: Address already in use: JVM_Bind
at java.net.DualStackPlainSocketImpl.bind0(Native Method)
--------------------------------------------
Cause:
These issues occur if the Spotfire server port is used by some other application. This error indicates that there is another application listening on the port number that the Spotfire Server is configured for.
Resolution:
Option 1: Check for any application that is listening to the same port and stop that application.
> Run the command at the command prompt with Administrator privileges: "netstat -ano > Port.txt & Port.txt"
e.g: C:\Users\username>netstat -ano > Port.txt & Port.txt
This will open the "Port.txt" notepad file and will list all the ports occupied/used on the machine. You can now search for the Spotfire Server port in question.
Option 2: Change the port number that Spotfire Server is using.
- Open the file server.xml located at <Spotfire Server install directory>\tibco\tss\<version>\tomcat\conf .
- Change "connector port= " to a different port which is not in use.- Save the file and restart the Spotfire Server service. Please refer 7.11 Spotfire Server installation manual:
https://docs.tibco.com/pub/spotfire_server/7.11.0/doc/pdf/TIB_sfire_server_7.11.0_installation.pdf
Comments
0 comments
Article is closed for comments.