Product: TIBCO Spotfire®
Error in TIBCO Spotfire Server log: "java.net.SocketException: Too many open files" on the LINUX Operating System
Description:
Spotfire Server is unresponsive and users are unable to login to Spotfire desktop client and Web Player. Error: "java.net.SocketException: Too many open files".
Symptoms:
(TSS) Spotfire Server logs show the following events.
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Dec XX, XXXX 8:09:XX AM org.apache.tomcat.util.net.JIoEndpoint$Acceptor run
SEVERE: Socket accept failed
java.net.SocketException: Too many open files
at java.net.PlainSocketImpl.socketAccept(Native Method)
at java.net.AbstractPlainSocketImpl.accept(AbstractPlainSocketImpl.java:398)
at java.net.ServerSocket.implAccept(ServerSocket.java:530)
at java.net.ServerSocket.accept(ServerSocket.java:498)
at org.apache.tomcat.util.net.DefaultServerSocketFactory.acceptSocket(DefaultServerSocketFactory.java:60)
at org.apache.tomcat.util.net.JIoEndpoint$Acceptor.run(JIoEndpoint.java:220)
at java.lang.Thread.run(Thread.java:744)
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Cause:
The error "java.net.SocketException: Too many open files" indicates that the limit on the number of "Open files", which is 1024 by default, has been exceeded.
This is an operating system issue. Increase the max open files parameter to a larger value for the user running the Spotfire Server process by adding the following two lines in the /etc/security/limits.conf file. Then, restart the Spotfire Server.
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<username> soft nofile 40000
<username> hard nofile 40000
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Example: If Spotfire is running under "root" user:
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root soft nofile 40000
root hard nofile 40000
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Note: An issue exists for a high number of open files under Red Hat 6. (Refer to https://access.redhat.com/solutions/33993). Consult with your Administrator before making any changes as the change outlined above will modify the parameter for the root user.
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