Product: TIBCO Spotfire®
Unable to access a file through a link in Web Player.
Within a Table visualization, we can edit a column's properties to make it open a file using thelinkrenderer, when a particular value is clicked on. This can be done by right-clicking on the Table visualization -> click on Properties -> click on Columns -> in the Selected Columns field, select a column -> click on the Renderer drop-down -> choose Link -> click on Settings -> specify the URL.
When the analysis is opened in the Spotfire Analyst desktop client, clicking on the link opens the file defined in the renderer. But when the analysis is opened in the Web Player, the link is not rendered when the user clicks on it. There is no message and no action.
Symptoms:
Clicking on a link in an analysis opened in the Web Player does not open or download the file. There is no message and no action.
Cause:
One of the causes is that the Web Player URL isn't trusted in Internet Explorer.
Follow these steps below to make the Spotfire Web Player URL trusted in Internet Explorer:
1). Open Internet Explorer.
2). Open Tools, then select Internet Options.
3). Click on the Security tab.
4). Click on Trusted Sites, then click on the Sites button.
5). Add the URL for TIBCO Spotfire Web Player to the list of trusted sites.
6). Reopen the Spotfire analysis file in the Web Player.
7). Verify that the link opens.
Note: If these options are disabled in Internet Explorer, you may need to contact your IT team to get this added site under Trusted Sites
Comments
0 comments
Article is closed for comments.