Product: TIBCO Spotfire®
Unable to start Spotfire Server service. "Error : The transaction log for database 'SPOTFIREDBNAME' is full due to 'LOG_BACKUP' "
Symptoms:
Spotfire server fails to start and the following error is seen in the "catalina.log" (<Spotfire Server Installation Directory>\tomcat\logs\).
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Caused by: java.lang.RuntimeException: Unable to load the configuration
at com.spotfire.server.lifecycle.SpotfireApplicationInitializer.populateServerNameAndVersion(SpotfireApplicationInitializer.java:336)
at com.spotfire.server.lifecycle.SpotfireApplicationInitializer.initRootContext(SpotfireApplicationInitializer.java:176)
.......
.......
Caused by: com.microsoft.sqlserver.jdbc.SQLServerException: The transaction log for database 'spotfire_server_production' is full due to 'LOG_BACKUP'.
at com.microsoft.sqlserver.jdbc.SQLServerException.makeFromDatabaseError(SQLServerException.java:217)
.......
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... 15 more
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Cause:
This ERROR indicates that there is a space issue on the Spotfire application database mentioned in the error message. The Spotfire Database failed to perform any transaction because of space issues.
Check with the Database Administrator for alternatives/possible solutions for responding to a full transaction log in order to free up space for Database transactions.
Note:
A similar "The transaction log for database 'SPOTFIREDBNAME' is full due to 'LOG_BACKUP' " error can occur in multiple places while performing any library operation if there is a space issue on an SQL based Spotfire application database.
https://msdn.microsoft.com/en-IN/library/ms175495.aspx
http://stackoverflow.com/questions/56628/how-do-you-clear-the-sql-server-transaction-log
http://stackoverflow.com/questions/17674973/the-transaction-log-for-the-database-is-full
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