Product: TIBCO Spotfire®
PDF file exported from Web Player fails to open.
Description:
PDF exported via Web Player fails to open. Error - Adobe Acrobat DC could not open 'xxxx.pdf' because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded).
Symptoms:
The following error is returned while opening the exported file via the Web Player.
"Adobe Acrobat DC could not open 'xxxx.pdf' because it is either not a supported file type or because the file has been damaged (for example, it was sent as an email attachment and wasn't correctly decoded)."
Cause:
This can be caused if the user does not have r/w permission to the Web Player temp folder. During the export process, the PDF file is generated to the IE temporary folder and then copied to the Web Player temp folder before it is downloaded to the client machine. As the user does not have permission to write to the Web Player temp folder, the copy to the temp folder is blocked and the result is an incomplete/corrupt file.
Resolution
Give users Read/Write access to the Web Player temp folder.
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