Description
In Image Artist 1.5, the following issues may occur and are typically caused by OpenSearch JVM direct memory exhaustion:
- A Batch Analysis job shows as "Completed" on the Job Status page, but the results do not appear in the user’s data tree.
- A Batch Analysis job fails with the error: “Registration failed.”
Cause
During the bulk upsert operation used to register Batch Analysis results, OpenSearch may exhaust its JVM direct memory (MaxDirectMemorySize).
When this occurs:
- Jobs may appear as "Completed", or show "Registration failed" in the Job Status page
- Results are not stored or displayed in the Image Artist data tree.
This condition is typically accompanied by the following error in the SImA_opensearch.log:
java.lang.OutOfMemoryError: Cannot reserve 1048576 bytes of direct buffer memory
For instructions on collecting Image Artist server logs, see:
Image Artist: Collecting the server logs
Workaround
Increase the OpenSearch JVM direct memory allocation.
- Locate the
custom.envfile in the Image Artist 1.5 installation directory. -
Add or update the following line to set the
MaxDirectMemorySizeto 512 MB.OPENSEARCH_JAVA_OPTS=-Xms512m -Xmx512m -XX:MaxDirectMemorySize=512m
- In environments processing large Batch Analysis jobs, you may need to increase this further (for example, 1–2 GB).
-
Redeploy the Image Artist stack
Refer to: Image Artist: How do I redeploy/restart the container stack?
Verify the Change (Optional)
After redeployment, confirm the new setting has been applied within the OpenSearch container:
docker exec $(docker ps --filter "name=opensearch" --format "{{.Names}}") printenv | grep "OPENSEARCH_JAVA_OPTS"
docker exec $(docker ps --filter "name=opensearch" --format "{{.Names}}") curl -s http://localhost:9200/_nodes/jvm,process?pretty | grep "MaxDirectMemorySize"
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