INTERNAL
System Admins can set a list of IP address ranges from which users can access the URL of the tenant. This configuration is found in "Signals Configuration" app -> "System Settings" -> "Authentication" -> "Restrict IP Access". This IP range restriction applies to not only access from GUI users but also API access.
When API calls are blocked by the IP range restriction, error responses they receive are not obvious. One example is shown below.
HTTP Status 401
{
"status": "401",
"code": "Unauthorized",
"title": "User is unauthorized",
"detail": "No x-api-key is found in request header or the value of x-api-key is invalid."
}
Comments
0 comments
Article is closed for comments.